freebsd
[Início] [Todas as Listas]

[FUG-BR] Problema com roteamendo ...

From: "Nilton Jose Rizzo" <rizzo@xxxxxxxxxxx>
To: Lista Brasileira de Discussão sobre FreeBSD (FUG-BR) <freebsd@xxxxxxxxxx>
Subject: [FUG-BR] Problema com roteamendo ...
Date: Fri, 28 Dec 2007 16:42:23 -0300

         Pessoal não sei mais o que fazer para achar a falha ....

         o caso é o seguinte:

         
              R ---- S1---+-------+--
                           \       \
                            |       |
                           FBSD1  FBSD2
                            |       |
                             \     /
                              +-+-+
                                |
                                S2

               S1 e S2 - Swichts

               Roteador R - placa interna A.B.C.129/26
               Roteador FBSD1 - Nat+IPFW+Squid
                        Placa Externa A.B.C.130/26
                        Placa Interna 10.0.0.0/24

               Roteador FSBD2 - Apenas roteador com Squid
                        Placa Externa A.B.C.132/26
                        Placa Interna A.B.C.200/26

   O Roteador FBSD1 e a rede 10.0.0.0/24 funciona perfeitamente sem problemas
              acesso externo via SSH/HTTP ok 

   O Roteador FBSD2  é o problema:

              dentro dele pingo para as duas redes e para fora do roteador
   R, porem na rede A.B.C.192/26 ninguem consegue sair, só através do squid

    Porém de qualquer máquina dentro da rede A.B.C.192/26 consigo pingar
    a placa de rede externa do FBSD2 (A.B.C.132), porem não consigo pingar
    o Roteador R (A.B.C.129) Acho que o calor torrou meu celebro
    ou então foi o alcol do natal que queimou o reuronio
    responsavel por essa informação ... :(

    Pelo que eu andei olhando através do trafshow  que o pacote de
    ping é enviado para o roteador R e não volta .... não consegui ver
    a solução .... que coisa heim .....

    PS.: Nessa máquina (FBSD2) não será utilizado o nat, estarei 
    utilizando os ips válidos de uma classe /26 fornecida pelo
    meu provedor

segue os arquivos rc.conf

# -- sysinstall generated deltas -- # Wed Dec 26 14:10:04 2007
# Created: Wed Dec 26 14:10:04 2007
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
#defaultrouter="A.B.C.129"
gateway_enable="YES"
hostname="server2"
ifconfig_rl0="inet A.B.C.132  netmask 255.255.255.192"
ifconfig_xl0="inet A.B.C.200  netmask 255.255.255.192"
keymap="br275.iso.acc"
ntpdate_enable="YES"
ntpdate_flags="-bntp.on.br"
sshd_enable="YES"
squid_enable="YES"

netstat -nr

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            A.B.C.129          UGS         0      565    rl0
127.0.0.1          127.0.0.1          UH          0       97    lo0
A.B.C.128/26       link#1             UC          0        0    rl0
A.B.C.129          00:60:2e:00:b0:8b  UHLW        4       45    rl0   1198
A.B.C.130          00:e0:4c:7b:5b:1c  UHLW        1       32    rl0    834
A.B.C.132          A.B.C.129          UGHS        0        0    rl0
A.B.C.192/26       link#2             UC          0        0    xl0
A.B.C.201          00:30:4f:03:15:87  UHLW        1      678    xl0    247
X.Y.Z.0/24         A.B.C.129          UG          0        0    rl0

server2# sysctl -a | grep forw
kern.smp.forward_roundrobin_enabled: 1
kern.smp.forward_signal_enabled: 1
net.inet.ip.forwarding: 1
net.inet.ip.fastforwarding: 0
net.inet6.ip6.forwarding: 0

server2# uname -a
FreeBSD server2.XXXX.com.br 7.0-BETA4 FreeBSD 7.0-BETA4 #0: Sun Dec  2
19:19:04 UTC 2007     root@xxxxxxxxxxxxxxxxxxxxx:/usr/obj/usr/src/sys/GENERIC
 i386
s
         
                                
-- 
Nilton José Rizzo 
805 Informatica 
Disseminado tecnologias 
021 2413 9786























<Anterior na Thread] Thread Atual [Próximo na Thread>